Ruby on rails安装后去掉DL is deprecated,please use Fiddle警告信息的方法【测试可用】

本文实例讲述了Ruby on rails安装后去掉DL is deprecated,please use Fiddle警告信息的方法。分享给大家供大家参考,具体如下:

问题:

搭建完完ruby on rails环境之后发现每次运行命令总会有这样一个Warning:DL is deprecated, please use Fiddle,例如:

对运行什么的没有影响,只是Dl过时了,可是Ruby大大不管这个问题,可是看着就烦呐~~

解决方法from stackflow):

找到安装目录D:\RailsInstaller\Ruby2.1.0\lib\ruby\2.1.0下的dl.rb将里面的warn一行注释掉即可:

require 'dl.so'

begin
 require 'fiddle' unless Object.const_defined?(:Fiddle)
rescue LoadError
end

#warn "DL is deprecated, please use Fiddle"

module DL
 # Returns true if DL is using Fiddle, the libffi wrapper.
 def self.fiddle?
  Object.const_defined?(:Fiddle)
 end
end

终于我们的世界又清净了许多!

希望本文所述对大家Ruby on rails程序设计有所帮助。

代码技巧

转载请关注公众号:代码技巧 回复:授权

本文链接地址:http://www.oudahe.com/p/34973/